4.3 Mercu Crusier in a 2008 196 LS

From the 176 Fish & Ski up to the 242LS Bow Rider...this is the forum for the LS Series and other Caravelle models.

4.3 Mercu Crusier in a 2008 196 LS

Postby Fredcollett » Sun Jan 22, 2017 10:31 am

Has anybody found a solution to the Dieseling problem after you shut off the key in the 4.3 engine ??
After a long run or after I tow the kids on a tube the engine will diesel when shut off,
apparently this problem has been around for several years
I have tried fuel additive , high octane gasoline, adjusting the idling , None seems to make a big difference
if I let the engine idle for 2 or 3 minutes, then it will shut off an not diesel
Fred
Fredcollett
Member
 
Posts: 15
Joined: Wed Jul 27, 2016 9:47 am
Location: London Kentucky
Occupation: Equipment manager
Interests: 0

Re: 4.3 Mercu Crusier in a 2008 196 LS

Postby youmansjason01 » Sun Jan 22, 2017 9:54 pm

Many years ago, I owned a 1997 Four Winns with a Volvo Penta 4.3 GL (carburetor version, not fuel injected) and it had the same problem. It was very frustrating because the engine ran great in all other respects.

Unfortunately, the only semi-cure I could find was the combination of running Premium Unleaded gas (93 octane) and after a hard run, letting it idle for a couple of minutes before shutting it off.
2007 Caravelle 237 LS
350 MAG 300HP with Bravo 1, Captain's Call Exhaust, Black wide band with matching Caravelle Trailer
User avatar
youmansjason01
Member
 
Posts: 135
Joined: Sat Dec 12, 2009 2:35 pm
Location: Buford, GA
Location:
Occupation:
Interests: 0


Return to Caravelle LS Series

Who is online

Users browsing this forum: No registered users and 1 guest

cron