New to forum-speedomotoer/water inside question

From the 176 Fish & Ski up to the 242LS Bow Rider...this is the forum for the LS Series and other Caravelle models.

New to forum-speedomotoer/water inside question

Postby Eric85 » Tue May 28, 2013 8:14 am

I am new the new owner of a 94 190ls. I took it out this weekend, and the speedomoter is not working. I disconnected the line at the transom and it is free. I blew through the line going into the boat and it seems free. I am not sure if that second part is good or not! I also noticed that I am getting some water in the boat while going across teh water, but not some much sitting still. Is it possible that the speedomoter tube has cracked and is letting water isndie? I am having a hard time finding out where exactly the line runs to get to the speedomotoer. Any help would be greatly appreciated!
Eric85
Member
 
Posts: 8
Joined: Mon May 13, 2013 2:38 pm
Location:
Occupation:
Interests: 0

Postby AndrewT » Tue May 28, 2013 8:21 am

Sounds like the speedo tube has got a hole or cut in in.
The faster you go the more water will be pouring in. :lol:
If you remove the speedo and apply some pressure to it from a compressor the needle should move if not the unit is seized . Faria gauges carry a lifetime warranty , give them a call .
2005 Interceptor 212
Volvo 5.0 GXi 270hp
21P 14.5 3B SS prop and 19P 4B SS for wakeboarding and tubing.
AndrewT
Member
 
Posts: 994
Joined: Sun Jun 27, 2010 8:56 am
Location: South Australia
Location: South Australia
Occupation: Sales Manager
Interests: 0

Re: New to forum-speedomotoer/water inside question

Postby Jax » Tue Sep 03, 2013 8:51 am

Speedometer could be a loose line somewhere or clogged. We used to disconnect from the back of the gauge and put air pressure to it to blow it out. That might help you find a leak in the line. That was back in the 70's, so I have no idea if they still work that way.

As far as the water, look closely at the keel. A thin spot or small crack might be water-tight while sitting still, but underway it might be letter in water. Was the case with our old boat from beaching and trailer rash.
2007 217LS
Volvo 5.0L GXi 270hp
Apollo XHS HP SS 14 1/4 X 20 prop
Jax
Member
 
Posts: 281
Joined: Mon Aug 13, 2007 11:56 am
Location: Fair Oaks Ranch, TX
Location:
Occupation:
Interests: 0

Re: New to forum-speedomotoer/water inside question

Postby HOT PURSUIT » Tue Sep 03, 2013 2:22 pm

Tube has a hole or blew off a joint. Look for the speedo line near where you are getting water in! Your description is exactly the symptoms for the problem.

HP
HOT PURSUIT
Member
 
Posts: 3510
Joined: Sat Apr 29, 2006 7:10 pm
Location: WISCONSIN
Location:
Occupation:
Interests: 0


Return to Caravelle LS Series

Who is online

Users browsing this forum: No registered users and 1 guest

cron