4.3 Mercu Crusier in a 2008 197 LS

Got a tip on maintenance. Need help with a repair? This is the place to ask.

4.3 Mercu Crusier in a 2008 197 LS

Postby Fredcollett » Sun Oct 09, 2016 2:05 pm

Bought boat used with 157 hrs on it 1 owner 4.3 V-6 190 hp 2 barrel carb / no choke plates / Mercury branded carb original equip.
boat had a issue with bogging when u punched the throttle wide open
engine / carb made a sucking noise just for a 2 or 3 seconds boat bogged and you had to double pump the throttle to get it to take fuel an get up on plane
a real pain in the but for towing, boat loading, dock parking
did a lot of research talked to and read articles from many mercury guys on different blogs
long and short of it
Fixed my problem by installing a new rockchester 2 barrel carburetor with a electric choke that had choke plates an linkage in the top of carb
talked to a guy out in Califorina, found him on ebay he sold me a brand new carb an mounting gasket and shipped it for 305.00
he said the carb on my 4.3 was built for Mercury and instood of a choke with plates and linkage it had a electric solenoid called a fuel enhancer and that they where pieces of carp would not last and ran the boat way to rich on fuel
swapped carbs about 2.5 hr job easy to re wire choke control , had to adjust idle screw after engine warmed up on the test run down the lake
Runs great, starts better, idles better, excels great jumps onto plane all around a huge improvement to my boat
Fredcollett
Member
 
Posts: 15
Joined: Wed Jul 27, 2016 9:47 am
Location: London Kentucky
Occupation: Equipment manager
Interests: 0

Re: 4.3 Mercu Crusier in a 2008 197 LS

Postby AndrewT » Mon Oct 10, 2016 4:02 am

Thanks for sharing the information.
Glad to see you got her sorted out.
2005 Interceptor 212
Volvo 5.0 GXi 270hp
21P 14.5 3B SS prop and 19P 4B SS for wakeboarding and tubing.
AndrewT
Member
 
Posts: 996
Joined: Sun Jun 27, 2010 8:56 am
Location: South Australia
Location: South Australia
Occupation: Sales Manager
Interests: 0

Re: 4.3 Mercu Crusier in a 2008 197 LS

Postby HOT PURSUIT » Mon Feb 20, 2017 7:47 pm

Good job :mrgreen:

HP
HOT PURSUIT
Member
 
Posts: 3510
Joined: Sat Apr 29, 2006 7:10 pm
Location: WISCONSIN
Location:
Occupation:
Interests: 0


Return to Maintenance / Repair

Who is online

Users browsing this forum: No registered users and 1 guest

cron