It just died, now won't fire

Got a tip on maintenance. Need help with a repair? This is the place to ask.

It just died, now won't fire

Postby Jax » Fri May 22, 2015 7:12 pm

8 years of good luck has ended.

Launched the boat, skeg hit a large piece of concrete and it snapped an inch off the bottom. No prop damage. This happened while backing into the Llano river arm of lake LBJ. We thought we had backed over debris, so we didn't know we had taken the end off the skeg. Lotta flood trash in the river.

Engine fired right up. Drove it about a half mile up river to the boat dock. While waiting for the boat lift to be lowered engine just died. This has never happened ever, so I knew something was up and I paddled in to the dock.

Now it will not fire at all. Acts exactly like the kill switch was pulled.

Kill switch works and is in place.
New battery and connections are good.
Full of gas.
Rained a little last night, but not much. Gas cap was snug.
No obvious disconnected wires.

Boat was used recently and put up full of fuel.

Is there an inline circuit breaker or fuse?
Tilt works fine, but is there some rear impact protection on the outdrive that might be tripped?
Fuel filter/line? Is there something there I could check?

Volvo Penta (see sig block)
Fuel injected

I'm not a mechanic, so talk slowly and don't use any big words! ;)

About to put another damper on family reunion. Weather isn't helping.

Thanks and hope everyone has a great Memorial Day weekend!

JP

p.s. Checked kill switch again. Turned key on, pulled kill switch, put it back on and got self-test chimes. Pretty simple switch.
2007 217LS
Volvo 5.0L GXi 270hp
Apollo XHS HP SS 14 1/4 X 20 prop
Jax
Member
 
Posts: 281
Joined: Mon Aug 13, 2007 11:56 am
Location: Fair Oaks Ranch, TX
Location:
Occupation:
Interests: 0

Re: It just died, now won't fire

Postby Jax » Fri May 22, 2015 7:40 pm

How do you check one of this big black, square fuses in the fuse box? Continuity with a volt meter?

Thanks.
2007 217LS
Volvo 5.0L GXi 270hp
Apollo XHS HP SS 14 1/4 X 20 prop
Jax
Member
 
Posts: 281
Joined: Mon Aug 13, 2007 11:56 am
Location: Fair Oaks Ranch, TX
Location:
Occupation:
Interests: 0

Re: It just died, now won't fire

Postby AndrewT » Sat May 23, 2015 5:10 am

Hi Jax,god that you double checked the kill switch,the big square fuses you are looking at may actually be relays,as per one of the previous topics
viewtopic.php?f=12&t=6684
you need to check for spark and fuel. I assume that she cranks over but she's not firing?
Can you hear the fuel pump whirl when you turn the ignition on? Did you check for spark?
This may help http://boatinfo.no/lib/volvo/manuals/5057a-f.html#/0
Good luck with your trouble shooting, please keep us posted.
2005 Interceptor 212
Volvo 5.0 GXi 270hp
21P 14.5 3B SS prop and 19P 4B SS for wakeboarding and tubing.
AndrewT
Member
 
Posts: 996
Joined: Sun Jun 27, 2010 8:56 am
Location: South Australia
Location: South Australia
Occupation: Sales Manager
Interests: 0

Re: It just died, now won't fire

Postby Jax » Sat May 23, 2015 10:14 am

Turn the key on, and you get a few seconds of fuel pump whine. Fuzes all check good. Easy way to check fuel flow with a fuel injected engine? Thanks guys!
2007 217LS
Volvo 5.0L GXi 270hp
Apollo XHS HP SS 14 1/4 X 20 prop
Jax
Member
 
Posts: 281
Joined: Mon Aug 13, 2007 11:56 am
Location: Fair Oaks Ranch, TX
Location:
Occupation:
Interests: 0

Re: It just died, now won't fire

Postby Jax » Sat May 23, 2015 10:59 am

Turns over normally. It was idling normally and died quickly. Made me think it was a fuze. It ran strong for five minutes or more prior, which made me think water in the gas wasn't a problem. Can't get fuel filter off, looking for a tool. About to check for spark between wire and spark plug. Having a hard time finding a volunteer. More as we go.
2007 217LS
Volvo 5.0L GXi 270hp
Apollo XHS HP SS 14 1/4 X 20 prop
Jax
Member
 
Posts: 281
Joined: Mon Aug 13, 2007 11:56 am
Location: Fair Oaks Ranch, TX
Location:
Occupation:
Interests: 0

Re: It just died, now won't fire

Postby Jax » Sat May 23, 2015 12:26 pm

FIXED. I'm a hero. No idea what I did.
2007 217LS
Volvo 5.0L GXi 270hp
Apollo XHS HP SS 14 1/4 X 20 prop
Jax
Member
 
Posts: 281
Joined: Mon Aug 13, 2007 11:56 am
Location: Fair Oaks Ranch, TX
Location:
Occupation:
Interests: 0

Re: It just died, now won't fire

Postby AndrewT » Sat May 23, 2015 7:26 pm

That is scary,hopefully it won't happen when you are in the middle of a big lake!
Wasn't the kill switch?
2005 Interceptor 212
Volvo 5.0 GXi 270hp
21P 14.5 3B SS prop and 19P 4B SS for wakeboarding and tubing.
AndrewT
Member
 
Posts: 996
Joined: Sun Jun 27, 2010 8:56 am
Location: South Australia
Location: South Australia
Occupation: Sales Manager
Interests: 0

Re: It just died, now won't fire

Postby Jax » Sun May 24, 2015 6:42 pm

Wasn't kill switch. Re-seating some wires was the likely fix.
2007 217LS
Volvo 5.0L GXi 270hp
Apollo XHS HP SS 14 1/4 X 20 prop
Jax
Member
 
Posts: 281
Joined: Mon Aug 13, 2007 11:56 am
Location: Fair Oaks Ranch, TX
Location:
Occupation:
Interests: 0

Re: It just died, now won't fire

Postby foyboy062 » Tue May 26, 2015 4:14 pm

After 35 years of car and boat repair I gonna say just one thing. ANYTIME you "fixed" something and don't know how you fixed it, YOU DIDN'T FIX IT. I'm just say'in. good luck, you can bet that something you touched effected the problem.
foyboy062
Member
 
Posts: 61
Joined: Thu May 31, 2012 9:30 am
Location:
Occupation:
Interests: 0

Re: It just died, now won't fire

Postby Jax » Tue May 26, 2015 6:43 pm

Apparently we have a different definition of fixed. I'm just sayin'. When the Volvo Penta mech tells me to try re-seating all wires and checking the ignition switch, and I do all that and it starts immediately and runs perfectly all 3 days -- I call it fixed. Beats having 19 people standing around watching me stare at the engine, like a pig staring at a wristwatch. :hammer:

I spent the next 3 days sitting on the dock with an ice cold beer in my hand :beer: watching the kids ski, tube, and board behind my boat that wasn't fixed. 8)
2007 217LS
Volvo 5.0L GXi 270hp
Apollo XHS HP SS 14 1/4 X 20 prop
Jax
Member
 
Posts: 281
Joined: Mon Aug 13, 2007 11:56 am
Location: Fair Oaks Ranch, TX
Location:
Occupation:
Interests: 0

Re: It just died, now won't fire

Postby sdk » Fri May 29, 2015 4:59 pm

With all the electronics on engines now, sometimes they have to reset themselves. I don't understand it either!!
2005 Caravelle Interceptor 232 BR SS
350 MAGMPI, Bravo 1
2014 Stingray 2LT Coupe
sdk
Member
 
Posts: 2188
Joined: Wed May 05, 2004 7:41 pm
Location: South Carolina
Location: South Carolina
Occupation:
Interests: 0

Re: It just died, now won't fire

Postby jfair32 » Fri Jun 24, 2016 11:52 pm

I had a similar issue and it was corrosion between the wires that are stacked back by battery. I pull them off every season, wire brush them and use wd40.
2005 232SC 350 Mag Red Tribal graphics
Dodge Ram Quad Cab 1500 HEMI
jfair32
Member
 
Posts: 159
Joined: Thu Aug 10, 2006 10:50 am
Location: Westmont, IL
Location:
Occupation:
Interests: 0

Re: It just died, now won't fire

Postby jfair32 » Fri Jul 29, 2016 10:45 pm

Oops, sorry this post is a bit old. :oops:
2005 232SC 350 Mag Red Tribal graphics
Dodge Ram Quad Cab 1500 HEMI
jfair32
Member
 
Posts: 159
Joined: Thu Aug 10, 2006 10:50 am
Location: Westmont, IL
Location:
Occupation:
Interests: 0


Return to Maintenance / Repair

Who is online

Users browsing this forum: No registered users and 1 guest

cron